DangerSwiftKantoku

0.2.0

DangerSwiftKantoku is a danger-swift plug-in to report xcresult in your PR.
yumemi-inc/danger-swift-kantoku

What's New

0.2.0

2024-02-29T06:52:36Z

What's Changed

New Contributors

Full Changelog: v0.1.1...v0.2.0

Build

DangerSwiftKantoku

A danger-swift plug-in report xcresult in your PR.

Install DangerSwiftKantoku

SwiftPM (Recommended)

  • Add dependency package to your Package.swift file which you import danger-swift

    // swift-tools-version:5.5
    ...
    let package = Package(
        ...
        dependencies: [
            ...
            // Danger Plugins
            .package(name: "DangerSwiftKantoku", url: "https://www.github.com/yumemi-inc/danger-swift-kantoku.git", from: "0.1.0"),
            ...
        ],
        ...
    )
  • Add the correct import to your Dangerfile.swift file

    import DangerSwiftKantoku

Marathon (Tool Deprecated)

  • Just add the dependency import to your Dangerfile.swift file like this:

    import DangerSwiftKantoku // package: https://github.com/yumemi-inc/danger-swift-kantoku.git

Usage

Perform the xcreult check with parseXCResultFile method which is available for DangerDSL instances

danger.kantoku.parseXCResultFile(at: "<#.xcresult file path#>", configuration: .default)

※ Please note that currently DangerSwiftKantoku only supports reporting Build Errors, Build Warnings, Analyze Warnings and Test Failures in your .xcresult file. We're in progress to add more features like reporting Test Coverage in the future.

Preview

Code above will make danger producing markdown messages like below

Normal Comment

Warnings
⚠️

DEBUG_INFORMATION_FORMAT should be set to dwarf-with-dsym for all configurations. This could also be a timing issue, make sure the Fabric run script build phase is the last build phase and no other scripts have moved the dSYM from the location Xcode generated it. Unable to process MyApp.app.dSYM at path /Users/vagrant/Library/Developer/Xcode/DerivedData/MyApp-fgkyrlpjfjuybodxuqbmvhrylall/Build/Products/Debug-Development-iphonesimulator/MyApp.app.dSYM

⚠️ Using 'class' keyword to define a class-constrained protocol is deprecated; use 'AnyObject' instead
⚠️

The iOS Simulator deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 8.0, but the range of supported deployment target versions is 9.0 to 15.0.99.

⚠️

MyApp/Source/Common/AttributedStringBuilder.swift#L94 - '@_functionBuilder' has been renamed to '@resultBuilder'

⚠️

MyApp/Source/UI/CommonViews/InitialStateView/InitialStateView.swift#L9 - 'whiteLarge' was deprecated in iOS 13.0: renamed to 'UIActivityIndicatorView.Style.large'

Generated by 🚫 Danger Swift against 8513f7535c90ed36b31d3ed6503ee37c5f9cab09

Inline Comment

  • ⚠️ Initialization of immutable value 'abc' was never used; consider replacing with assignment to '_' or removing it

Description

  • Swift Tools 5.7.0
View More Packages from this Author

Dependencies

Last updated: Mon Jun 24 2024 11:31:19 GMT-0900 (Hawaii-Aleutian Daylight Time)