websocket-kit

2.6.1

WebSocket client library built on SwiftNIO
vapor/websocket-kit

What's New

Remove use of NIOAtomics in favor of Atomics

2022-08-08T16:18:25Z
This patch was authored by @MahdiBM and released by @0xTim.

The Problem

Starting with SwiftNIO 2.41.0, NIOAtomics is deprecated in favor of Atomics.
This produces a warning if you use SwiftNIO 2.41.0 or higher.

Modifications

This PR add a dependency to Atomics to change the only use of NIOAtomics to Atomics, and suppress the warning.

What Warning?!

path/to/package/.build/checkouts/websocket-kit/Sources/WebSocketKit/WebSocketClient.swift:40:22: warning: 'NIOAtomic' is deprecated: please use ManagedAtomic from https://github.com/apple/swift-atomics instead
    let isShutdown = NIOAtomic.makeAtomic(value: false)
                     ^

Description

  • Swift Tools 5.4.0
View More Packages from this Author

Dependencies

Last updated: Tue Dec 06 2022 21:31:07 GMT-0500 (GMT-05:00)