SwiftLintPlugin

0.0.4

A Swift Package Plugin for SwiftLint
lukepistrol/SwiftLintPlugin

What's New

0.0.4

2022-09-02T07:24:21Z

GitHub Twitter: @lukeeep_

SwiftLintPlugin

A Swift Package Plugin for SwiftLint that will run SwiftLint on build time and show errors & warnings in Xcode.

Once SwiftLint offers their own implementation, this will be obsolete.

Implementation proposed here by @marcoboerner.

Add to Package

First add a dependency from this package:

dependencies: [
    // ...
    .package(url: "https://github.com/lukepistrol/SwiftLintPlugin", from: "0.0.1"),
]

Then add it to your targets as a plugin:

targets: [
    .target(
        name: "YOUR_TARGET",
        dependencies: [],
        plugins: [
            .plugin(name: "SwiftLint", package: "SwiftLintPlugin")
        ]
    ),
]

Buy Me A Coffee

Description

  • Swift Tools 5.6.0
View More Packages from this Author

Dependencies

  • None
Last updated: Mon Oct 03 2022 08:26:07 GMT-0500 (GMT-05:00)