PMKFoundation

3.3.4

Promises for Swift & ObjC
PromiseKit/Foundation

What's New

3.3.4

2019-10-11T19:58:28Z

Fix Linux Swift 5.1 compiles.

PromiseKit Foundation Extensions Build Status

This project adds promises to the Swift Foundation framework.

We support iOS, tvOS, watchOS, macOS and Linux, Swift 3.0, 3.1, 3.2, 4.0, 4.1, 4.2 and 5.0.

CococaPods

pod "PromiseKit/Foundation", "~> 6.0"

The extensions are built into PromiseKit.framework thus nothing else is needed.

Carthage

Note we can no longer support Swift 3 with Carthage due to Xcode 10.2 dropping it and our only being able to provide a single .xcodeproj.

github "PromiseKit/Foundation" ~> 3.0

The extensions are built into their own framework:

// swift
import PromiseKit
import PMKFoundation
// objc
@import PromiseKit;
@import PMKFoundation;

SwiftPM

package.dependencies.append(.package(url: "https://github.com/PromiseKit/Foundation.git", from: "3.0.0"))

Description

  • Swift Tools 5.0.0
View More Packages from this Author

Dependencies

Last updated: Sun Sep 11 2022 02:24:33 GMT-0500 (GMT-05:00)